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HP Scanjet - Scanner software installation fails when Quick Heal Antivirus is enabled in Windows 7

Issue

HP Scanjet software and driver installation fails when Quick Heal Antivirus is enabled in Windows 7. This document applies to Scanjets with HP Solution Center software (see the Products Affected section below).
The most common scenario includes the following symptoms:
  • The original installation of HP software works without issue.
  • When a second install is attempted, either over the previously installed software or after uninstalling the previously installed software, the install appears to complete in that all install steps are started and a popup message to connect the USB cable is displayed.
  • The actual software installation step, “Installing 1 of X: (software product name)” never starts.
  • The following HP screen is displayed at the beginning of the installation with an alert "Running Anti-Virus software can slow the installation process significantly and may cause a failure.":

Solution

Temporarily disable Quick Heal Antivirus, uninstall HP scanner software, remove the associated Hewlett-Packard directory from the registry, reinstall HP scanner software, and then re-enable Quick Heal Antivirus.
note:
It is important that you reboot the computer when instructed in the following steps.

Step one: Disable Quick Heal Antivirus

Temporarily disable Autorun Protection prior to installing or uninstalling HP Scanjet Software and Drivers. To do this, follow these steps:
  1. Open Quick Heal Antivirus and click External Drives & Devices.
  2. Turn OFF Autorun Protection and click Back to Dashboard to confirm.
  3. Make sure Autorun Protection is disabled and then close the Quick Heal AntiVirus window.
  4. Reboot the computer.
    note:
    Without the reboot, Quick Heal AntiVirus functions will remain active and can continue hindering install/uninstall attempts.

Step two: Uninstall HP software

Uninstall all HP software associated with the Scanjet in question.
  1. Disconnect the USB cable from the product. For scanners on a network, skip this step.
  2. Click Start, click Control Panel, click Programs, and then select Uninstall a program.
  3. Uninstall all HP programs associated with the device.
    1. Check whether any of the following programs are listed:
      • HP Imaging Device Functions
      • HP Photosmart Essential
      • HP Scanjet (with product name and software version number)
      • HP Solution Center
      • HP Update
      • HP OCR Software
      • OCR Software by I.R.I.S
      note:
      Do not remove any HP items other than those mentioned above if the computer is manufactured by HP or Compaq.
    2. For each program listed, click the program name and then click Uninstall.
  4. Wait while the computer reboots.
    note:
    Uninstalling HP Photosmart Essentials and/or HP Solution Center will force the system to reboot. If for some reason a reboot does not occur automatically, restart the computer before continuing.

Step three: Remove the Hewlett-Packard directory or key from the registry

  1. Clean up the registry.
    note:
    This step can result in unintended consequences to the scanning system and can destabilize or alter the functionality of the computer, therefore, HP does not recommend manually editing the Windows Registry or manually deleting driver files without assistance. Only individuals with extensive knowledge of the registry and registry modifications should perform the steps below. Novice computer users should seek assistance from an HP technical support agent. If you are not comfortable performing these steps or are not sure, contact HP Support for assistance in performing these steps.
    1. Open the registry folder HKEY_LOCAL_MACHINE, open SOFTWARE, and then locate the Hewlett-Packard folder.
    2. Export the HKEY_LOCAL_MACHINE\SOFTWARE\Hewlett-Packard directory to a safe location, and then remove it from registry.
      note:
      In most cases it is this entry that is not getting cleaned up properly during uninstalls and prevents subsequent installs. Care should be taken when other HP devices are connected to the PC. If, after installing HP Solution Center successfully, another HP device is not working properly, the exported directory key data can be added back to the HKEY_LOCAL_MACHINE\SOFTWARE\Hewlett-Packard directory by double-clicking on the exported directory.
  2. Reboot the computer.

Step four: Install the HP scanner software and driver

  1. Insert the CD that came with the product or install using the downloaded software and driver.
  2. Follow the onscreen wizard prompts to complete the installation.

Step five: Re-enable Quick Heal AntiVirus

  1. Re-enable Quick Heal AntiVirus.
  2. Reboot the computer again.
If after completing the steps above the issue persists, repeat all of the above steps and then, in addition to disabling Autorun Protection, disable ALL of the active functions in Quick Heal AntiVirus.

Cause

This issue occurs when the installation has been blocked by the Quick Heal AntiVirus application, typically when its Autorun Protection function is active.
Figure : Quick Heal Dashboard with all functions enabled including Autorun Protection

Products

This document applies to the following scanners only:
  • HP Scanjet G2410 Flatbed Scanner
  • HP Scanjet G2710 Photo Scanner
  • HP Scanjet G3010 and G3110 Photo Scanners
  • HP Scanjet G4010 and G4050 Photo Scanners
  • HP Scanjet N6310 Document Flatbed Scanner
  • HP Scanjet N6350 Networked Document Flatbed Scanner
  • HP Scanjet 2400 Digital Flatbed Scanner
  • HP Scanjet 3800 Photo Scanner
  • HP Scanjet 4370 Photo Scanner
  • HP Scanjet 5590 Digital Flatbed Scanner series
  • HP Scanjet 7650 and 7650n (Networked) Document Flatbed Scanner series
  • HP Scanjet 8270 Document Flatbed Scanner
  • HP Scanjet 8300 Digital Flatbed Scanner
  • HP Scanjet 8350 and 8390 Document Flatbed Scanners