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HP LaserJet Enterprise M607-M609, Managed E60055-E60075, E60155-E60175 - The printer control panel screen is blank

Issue

The control panel screen on the printer is blank and does not respond to touch, or when buttons are pressed (on non-touchscreen models).

Possible causes

Some possible causes of a blank control panel screen are as follows:
  • No power
  • Defective power strip or power surge
  • The control panel connector is not securely seated
  • The memory card is missing, faulty, installed wrong, or not seated properly
  • Faulty component installed on the formatter (memory card, USB device, etc.)
  • Faulty power supply

Solution

Try the following steps to resolve the issue:

Step one: Check the power connection

Follow these steps to check the power connection:
  1. Make sure that the power cable is securely connected to the rear of the printer.
  2. Make sure that the power cable is connected to a working wall outlet, not a power strip or UPS.
  3. Test the wall outlet by plugging in a known working device.
  4. Make sure you are using the power cable that came with the printer.
  5. Press the Power button on the front of the printer.
    If the printer does not turn on and/or the control panel screen remains blank, continue to the next step.

Step two: Contact HP Customer Support

If the issue persists after confirming that there are not any issues with the power connection, contact your HP-authorized service or support provider, or contact HP Customer Support.
In preparation for your call with HP Customer Support, it is helpful if you can review the following questions and make note of your answers. This information will help the support agent to diagnose the issue.
  • Are there any visible lights (LEDs or back light on the control panel) working on the printer?
  • Does the printer make any noise (such as a fan running, boot sequence noises, or sounds from the engine?


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