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HP Designjet 4000, 4500, T610, T1100 and Z Printer Series - Mirrored Images not Correctly Positioned on the Page

Depending on the contents of the image, a positioning error can occur, when using the ‘Mirroring’ feature in the HP-GL/2 driver. This document describes the symptoms and available workarounds for this issue.
Symptoms
Depending on the contents of the original image, the mirrored image may appear to have shifted from its expected position. This only happens when the image is not aligned to the border of the page.
For example:
Figure : Mirrored image
In the first case, the image is aligned with the border and it will correctly mirror. This will be the case for all drawings that have a bounding box around the image which fits with the printer’s margins.
In the second case, there is some white space in the content of the image. When mirroring, this white space will be removed and the mirrored image will be incorrectly aligned with the margin of the paper, resulting in a shift in the contents.
Root cause
The root cause of this issue has been identified in the printer’s firmware (the issue is independent from the driver version). An algorithm that removes unnecessary white space from swaths, which improves processing performance, is applied before the mirroring is processed. This results in the mirrored image being incorrectly shifted from its expected position.
HP is working on applying the necessary firmware changes that will prevent this issue from occurring.
Workaround
There is a simple workaround which consists of sending the image as a bitmap/raster. When this is done, the workflow does not apply the algorithm that removes the white space, which results in the shifting of position of the mirrored image.
To apply this workaround:
  1. For HP Designjet T610/T1100, Z2100, Z3100, Z6100 (HP-GL/2 drivers):
    1. In the driver’s printing preferences, go to the Advanced tab.
    2. Printer features Send job as bitmap Set to enabled.
  2. For the HP Designjet 4000/4500:
    1. In the driver’s printing preferences, go to the Services tab.
    2. Click on the Troubleshoot Software problems button.
    3. Check the option Send job as bitmap (may be named Send job as raster in some driver versions).

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