ฝ่ายสนับสนุนลูกค้า HP - ฐานความรู้
  • ข้อมูล
    เรียนรู้วิธีอัปเกรดเป็น Windows 11

    คู่มือการอัปเกรด Windows 11

  • ข้อเสนอแนะ

เครื่องพิมพ์เอนกประสงค์ HP - เครื่องพิมพ์ไม่ยอมพิมพ์งานหลังจากอัพเกรดเป็น Windows 7

ปัญหา

แนวทางแก้ไขปัญหาในเอกสารนี้ระบุถึงปัญหาของเครื่องพิมพ์ที่ไม่ยอมพิมพ์งานหลังจากอัพเกรด Windows Vista เป็น Windows 7 อาการต่อไปนี้อาจเกิดขึ้นมาพร้อมกัน ทั้งนี้เอกสารชุดนี้ไม่ได้กล่าวรายละเอียดเกี่ยวกับอาการอื่น ๆ เหล่านี้ไว้
  • เครื่องพิมพ์ไม่ทำงาน
  • งานพิมพ์ติดค้างในคิวพิมพ์
  • ไม่มีการตอบรับจากเครื่อง

แนวทางที่หนึ่ง: ใช้เครื่องมืออัตโนมัติเพื่อลบไดร์เวอร์เครื่องพิมพ์

บันทึก
ขั้นตอนเหล่านี้หลายครั้งต้องมีการรีสตาร์ทเครื่อง สามารถทำบุ๊กมาร์กไว้ที่เว็บเบราเซอร์ เพื่อให้สามารถอ้างอิงได้หลังจากรีสตาร์ทเครื่องแล้ว
ทำตามขั้นตอนต่อไปนี้ตามลำดับที่แจ้งเพื่อแก้ไขปัญหา

ขั้นตอนที่หนึ่ง: ถอนการติดตั้งผลิตภัณฑ์ HP

ขั้นตอนที่สอง: ดาวน์โหลด และจากนั้นใช้ Printer Driver Removal Utility (ยูทิลิตี้ลบไดร์เวอร์เครื่องพิมพ์)

  1. คลิกที่ลิงค์นี้: Printer Driver Removal Utility (ยูทิลิตี้ลบไดร์เวอร์เครื่องพิมพ์)
  2. ทำตามคำแนะนำบนหน้าจอเพื่อบันทึกซอฟต์แวร์ไว้ในคอมพิวเตอร์ของคุณ
  3. เปิดโฟลเดอร์ที่บันทึกซอฟต์แวร์ไว้ (ส่วนใหญ่จะเป็นโฟลเดอร์ Downloads) ดับเบิลคลิกที่ไฟล์ จากนั้นทำตามคำแนะนำบนหน้าจอเพื่อให้โปรแกรมยูทิลิตี้ทำงาน และลบไดร์เวอร์เครื่องพิมพ์ออกจากคอมพิวเตอร์ของคุณ
  4. ทำตามขั้นตอนต่อไป

ขั้นตอนที่สาม: ติดตั้งซอฟต์แวร์ล่าสุดจากเว็บไซต์ HP

  1. เปิดเครื่องพิมพ์
  2. หากเครื่องพิมพ์ของคุณเชื่อมต่อกับคอมพิวเตอร์ผ่านสาย USB ให้ถอดสาย USB ออกจากเครื่องพิมพ์
  3. หากได้รับแจ้ง ให้เลือกวิธีการระบุรุ่นของเครื่องพิมพ์ และจากนั้น ทำตามหน้าจอคำแนะนำเพื่อไปที่หน้าดาวน์โหลด
  4. คลิกที่ Download (ดาวน์โหลด) ติดกับไดร์เวอร์ตัวเต็ม (แนะนำ) หรือคลิก Basic Drivers (ไดรเวอร์พื้นฐาน) สำหรับตัวเลือกไดร์เวอร์อื่น ๆ
  • หากขั้นตอนเหล่านี้สามารถแก้ไขปัญหาได้ คุณไม่ต้องแก้ไขปัญหาใด ๆ อีก
  • หาก ปัญหายังมีอยู่ ให้ทำตามแนวทางแก้ไขถัดไป

แนวทางที่สอง: ลบไดร์เวอร์เครื่องพิมพ์ออกด้วยตัวเอง

ทำตามขั้นตอนต่อไปนี้ตามลำดับที่แจ้งเพื่อแก้ไขปัญหา

ขั้นตอนที่หนึ่ง: ถอนการติดตั้งผลิตภัณฑ์ HP

ขั้นตอนที่สอง: ลบไดร์เวอร์และแพ็คเกจของไดร์เวอร์

  1. จากทาสก์บาร์ Windows คลิกที่ไอคอน Windows ()
  2. ในกล่องข้อความ Search programs and files (ค้นหาโปรแกรมและไฟล์) พิมพ์ (พิมพ์)
  3. ในหน้าต่างที่เปิดอยู่ คลิกPrint Management (การจัดการงานพิมพ์) หน้าต่าง Print Management (การจัดการงานพิมพ์) จะเปิดขึ้นมา
  4. ในบานหน้าต่างด้านซ้าย ดับเบิลคลิกที่ Print Servers (เซิร์ฟเวอร์การพิมพ์) คลิกขวาที่ไอคอนคอมพิวเตอร์ของคุณ และจากนั้น คลิกProperties (คุณสมบัติ) หน้าต่าง Print Server Properties (คุณสมบัติเซิร์ฟเวอร์การพิมพ์) จะปรากฏขึ้นมา
    บันทึก
    ภาพนี้อาจไม่เหมือนกับหน้าต่างบนคอมพิวเตอร์ของคุณ แต่คำแนะนำจะเหมือนกัน
      รูปภาพ : หน้าต่างการจัดการการพิมพ์
      ภาพประกอบ: หน้าต่าง Print Management (การจัดการงานพิมพ์)
    1. ตัวเลือกเซิร์ฟเวอร์การพิมพ์
    2. ไอคอนคอมพิวเตอร์
  5. คลิกที่แท็บ Drivers (ไดร์เวอร์) คลิกเพื่อไฮไลต์ชื่อผลิตภัณฑ์ HP ที่คุณต้องการลบ และจากนั้น คลิก Remove (ลบ) หน้าต่าง Remove Driver and Package (ลบไดร์เวอร์และแพ็คเกจ) จะเปิดขึ้นมา
  6. คลิก Remove driver and driver package (ลบไดร์เวอร์และแพ็คเกจไดร์เวอร์) และจากนั้น คลิก OK (ตกลง)
    รูปภาพ : หน้าต่าง Remove Driver And Package (ลบไดร์เวอร์และแพ็คเกจ)
    ภาพประกอบ: หน้าต่าง Remove Driver and Package (ลบไดร์เวอร์และแพ็คเกจ)
  7. เมื่อเสร็จสิ้นการลบไดร์เวอร์ คลิก Apply (นำไปใช้) และจากนั้น รีสตาร์ทคอมพิวเตอร์

ขั้นตอนที่สาม: ติดตั้งซอฟต์แวร์ล่าสุดจากเว็บไซต์ HP

  1. เปิดเครื่องพิมพ์
  2. หากเครื่องพิมพ์ของคุณเชื่อมต่อกับคอมพิวเตอร์ผ่านสาย USB ให้ถอดสาย USB ออกจากเครื่องพิมพ์
  3. หากได้รับแจ้ง ให้เลือกวิธีการระบุรุ่นของเครื่องพิมพ์ และจากนั้น ทำตามหน้าจอคำแนะนำเพื่อไปที่หน้าดาวน์โหลด
  4. คลิกที่ Download (ดาวน์โหลด) ติดกับไดร์เวอร์ตัวเต็ม (แนะนำ) หรือคลิก Basic Drivers (ไดรเวอร์พื้นฐาน) สำหรับตัวเลือกไดร์เวอร์อื่น ๆ

สาเหตุ

เมื่อคุณติดตั้งไดร์เวอร์เครื่องพิมพ์บน Windows 7 สำหรับผลิตภัณฑ์ของคุณ ตัวติดตั้ง Windows 7 ไม่ได้ลบไดร์เวอร์เครื่องพิมพ์บน Windows Vista อย่างถูกต้อง Windows 7 จะพยายามใช้ไดร์เวอร์เครื่องพิมพ์บน Windows Vista แทนที่จะเลือกใช้ไดร์เวอร์เครื่องพิมพ์ที่ถูกต้องบน Windows 7 ซึ่งอาจทำให้เกิดปัญหานี้


ประเทศ/ภูมิภาค: Flag ไทย