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HP UPD - Cannot install or update HP UPD V3 print drivers on a remote computer or server after installing Microsoft updates

Learn about an issue involving printer driver installations or updates via Point and Print.

Issue

Cannot install HP UPD V3 print drivers using Point and Print after installing a Microsoft Security Update.

Note:

Shared printers with an HP Product specific PCL-6 V4 driver installed will not experience this issue.

After updating to the Microsoft Security Update August 10, 2021, users are unable to install or update an HP UPD V3 print driver on a print server clients via Point and Print when the Windows client does not have admin rights.

Print server clients that do not have admin rights are not able to perform the following tasks: 

  • Install new printers using drivers on a remote computer or server

  • Update existing printer drivers using drivers from a remote computer or server

  • Connect to shared printers

Background

A remote code execution vulnerability exists when the Windows Print Spooler service improperly performs privileged file operations. An attacker who successfully exploits this vulnerability could run arbitrary code with SYSTEM privileges. An attacker could then install programs; view, change, or delete data; or create new accounts with full user rights.

Microsoft released a patch to resolve the security vulnerability: Windows Print Spooler Remote Code Execution Vulnerability (PrintNightmare)https://msrc.microsoft.com/update-guide/vulnerability/CVE-2021-34527.

Cause

Microsoft security patch updates which contain the resolution for PrintNightmare were included in recent Windows updates.

These updates prevent non-administrators, including delegated admin groups like printer operators, from installing signed and unsigned printer drivers to a print server. By default, only administrators can install both signed and unsigned printer drivers to a print server.

As a result, Windows updates released August 10, 2021 and later will, by default, require administrative privilege to install drivers.

Note:

This is expected behavior by Microsoft for enhancing security, which is not exclusive to HP. Contact Microsoft if you have inquiries.

Workaround

Learn how to install or update an HP UPD printer driver(s) on a remote computer or server.

Users can either elevate their Windows client privileges to administrator or follow the recommendations provided by Microsoft for potential workarounds.

Go to Microsoft support document Manage new Point and Print default driver installation behavior (CVE-2021-34481) (KB5005652). For questions regarding the workarounds, please contact Microsoft.


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