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HP Officejet X Printer Series - The product will not print if the product's IP address changes and the product and the computer are on different network subnets

Issue:

If you installed the HP software using the CD that shipped with your product, print jobs might fail to print if the printer’s IP address changes and the printer and the computer are on different network subnets.
Solution

Try the following solutions in the order presented. If one solution resolves the issue, you do not need to continue troubleshooting.
Solution one: Uninstall and reinstall the HP software
  1. From Windows Control panel, remove the printer.
  2. Re-install the printer by inserting the HP in-box CD and selecting the Connect a new printer flow.
Solution two: Set a static IP address
Access the HP Embedded Web Server (EWS) to set a static IP address. Refer to your printer’s documentation for more information.
Cause

The in-box HP software may not be able to detect the printer if the printer’s IP address changes and the printer and the computer are on different network subnets.

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