hp-support-head-portlet

Actions
Loading...
HP Customer Support - Knowledge Base

hp-contact-secondary-navigation-portlet

Actions
Loading...

hp-share-print-widget-portlet

Actions
Loading...
  • Information
    Fix HP Printer issue on macOS

    A [software component] will damage your computer message displays when printing or while installing - Click Here

    Information

    Audio or sound issues? Try our automated HP Audio check!

    Information

    Fix and resolve Windows 10 update issue on HP Computer or Printer. Click here

    Information
    Create an HP account today!

     Connect with HP support faster, manage all of your devices in one place, view warranty information and more. Learn more​

hp-concentra-wrapper-portlet

Actions
Loading...

HP FutureSmart - Latest Firmware Versions

Introduction

This document lists the most current version of firmware available for current, high-end printer models and is intended primarily for system administrators in a business environment. High-end printer models include the following categories:
  • HP LaserJet Enterprise
  • HP LaserJet Managed
  • HP PageWide Enterprise, and
  • HP PageWide Managed
note:
For printers not listed below, go to www.hp.com/support to locate firmware versions that are available for download.
This document is updated after each firmware roll and was last verified May 10, 2020.

Before you begin

Before upgrading firmware, make sure that any solutions used with the HP printer(s) will support the new firmware version. If a solution also needs to be updated to support the new firmware, HP recommends updating the solution to the latest version before updating the printer firmware.
Enhanced security features and settings implemented in recent firmware releases coupled with device resets might block the installation of some solutions. For more information, see the white paper Overview of Secure by Default Settings for Solutions.
If device resets are performed as part of the firmware upgrade process, be aware the solutions may need to be reinstalled or reconfigured.

HP FutureSmart 3 vs. HP FutureSmart 4

Many Enterprise and Managed printers have two versions of firmware to choose from: HP FutureSmart 3 and HP FutureSmart 4. Depending on the firmware version, the printer control panel display will differ.
  caution:
Downgrading from FutureSmart 4 to FutureSmart 3 will result in a loss of custom settings. Before upgrading to FutureSmart 4, go to the FutureSmart Navigation Compass to review the display differences and any feature modifications.
Figure : FutureSmart 4 control panels
Figure : FutureSmart 3 control panels

How to perform a firmware update

For supported upgrade methods, see the ReadMe file for each printer.
note:
Fixes and new features from earlier firmware releases are also contained in the newest firmware version (e.g. version 4.8 contains new features/fixes provided in 4.8, 4.7, 4.6, etc.).
Most update methods assume that the printer is network-connected, and that the firmware will be updated remotely unless USB flash drive is listed as an available upgrade method. To update multiple printers at one time, use the HP Web Jetadmin method.
ENTERPRISE or MANAGED (FutureSmart) methods
  caution:
Downgrading from FutureSmart 4 to FutureSmart 3 will result in a loss of custom settings. Before upgrading to FutureSmart 4, go to the FutureSmart Navigation Compass to review the display differences and any feature modifications.
HP Enterprise printers have a compressed .zip file for all operating systems that contains a .bdl firmware file that can be installed using one or more of the following methods:
  • Embedded Web Server (EWS) using the .bdl file
  • USB flash drive method using the .bdl file
  • Web Jetadmin (update multiple printers at one time) using the .bdl file
For instructions, go to one of the following support documents:

Footnotes

1
If you attempt to downgrade the firmware from a remote location to a version older than FutureSmart Bundle Version 3.8 for this newer HP Enterprise printer model, the downgrade will fail and you will receive a 99.02.32 control panel error and a 33.05.09 event log message.
This is due to a new security feature that requires someone to be present at the printer in order to perform a firmware downgrade and prevents HP SureStart printers from being downgraded remotely. This applies to HP Enterprise models M506, M552, M553, M577,M604, M605, and M606. Other HP Enterprise printer models will not experience this issue. For more information about this feature, go to Embedded Security features.
HP recommends using the latest firmware available but if a downgrade is absolutely necessary, then use the Preboot menu at the control panel to downgrade the firmware and avoid any errors. Any attempt to downgrade the firmware remotely-- or to downgrade using the Device Maintenance menu, the printer’s EWS, or Web Jetadmin-- will result in an error and the downgrade will fail.
2
For printers that support both HP FutureSmart 3 (FS3) and HP FutureSmart 4 (FS4) levels, both levels of the latest firmware versions will be listed including bundle version, firmware revision, and date code. If only one level is supported, only that level is listed.

hp-feedback-input-portlet

Actions
Loading...

hp-feedback-banner-portlet

Actions
Loading...

hp-country-locator-portlet

Actions
Loading...
Country/Region: Flag Bulgaria

hp-detect-load-my-device-portlet

Actions
Loading...