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HP FutureSmart - "The default sign-in method (Login) is currently unavailable." error might display when using SafeQ Cloud Pull Print solution

Learn how to resolve an authentication error message on printers running FutureSmart 5.7.1.1 firmware version when using the SafeQ Cloud (OXPd) Pull Print solution.

Issue

A "Sign-in failed" or "The default sign-in method (Login) is currently unavailable." error message might display on the control panel when a user is attempting to sign in to the SafeQ Cloud Pull Print app on a printer running FutureSmart 5.7.1.1 firmware version.

Note:

This issue might not occur on HP LaserJet Enterprise and Managed printers with FutureSmart 5.7 firmware version and does not occur on printers set up with SafeQ Cloud Workpath app.

Sign-in failed error message

Sign-in failed error message
Note:

This issue applies to the YSoft’s SafeQ Cloud OXPd-based solution Pull Print.

Pull Print feature on control panel

Pull Print feature on control panel

Cause

This issue occurs due to the new security measures implemented in HP FutureSmart firmware 5.7.1.1. Printers upgraded to HP FutureSmart 5.7.1.1 firmware version require the fully qualified domain name (FQDN) or a simple hostname to be configured in SafeQ Cloud solution settings.

The security feature validates if the FQDN or simple Hostname settings are configured in SafeQ Cloud certificate solution, and must match the printer network settings.

Applicable printers

This issue applies to HP LaserJet Enterprise and HP Managed printers running FutureSmart 5.7.1.1 firmware version using the SafeQ Cloud (OXPd) solution hosted by YSoft.

Resolve Sign-in failed error message

To resolve the Sign-in-failed error message, ensure the Fully Qualified Domain Name (FQDN) or simple Hostname in the printer network settings is configured in the SafeQ Cloud solution certificate settings.

Important:

If the printer has a Domain Name listed in the Network settings, then the simple Hostname in the SafeQ Cloud software should be the FQDN. If the network printer settings do not include a Domain Name, then a simple Hostname is sufficient for the SafeQ Cloud software deployment.

  1. Set up a Fully Qualified Domain Name (FQDN) or simple Hostname for the printer network.

    1. Open the Embedded Web Server (EWS).

    2. Select the Networking tab.

    3. In the left pane, select TCP/IP Setttings.

    4. On the TCP/IP Settings page, select the Network Identification tab.

    5. Enter the Host Name or Domain Name.

    6. Make sure to enter the required information for the network settings, and then click Apply.

    7. In the Summary tab, ensure the Domain name is listed in Fully Qualified Domain Name (IPv4/IPv6) under the TCP/IP(v4) Settings section.

  2. Configure the SafeQ Cloud solution certificate settings.

    1. Open the SafeQ Cloud solution certificate settings.

    2. On the Basic Options tab, enter the FQDN or simple Hostname in the Domains field to set up the Fully Qualified Domain Name (FQDN) name or Hostname.

      The FQDN or simple Hostname should be the same name configured in the printer network settings.

      Note:

      This will vary depending on how the printer is configured.

      FQDN in SafeQ Cloud solution certificate settings

      FQDN in SafeQ Cloud solution certificate settings
    3. On the Certificates tab, install a new CA certificate for the FQDN or simple Hostname.

      New certificate for the FQDN

      New certificate for the FQDN
    4. Under the General setup settings, make sure the FQDN name or simple Hostname is listed in the Server domains section.

      Note:

      The FQDN name listed in the SafeQ Cloud solution must be the same as the FQDN set in the printer network settings.

  3. Redeploy the (OXPd) software to the printer using the FQDN.

  4. Attempt to sign-in using the Pull Print app.